Merhabalar arkadaşlar, Sitemizi programlama ile ilgilenen bütün arkadaşlarımızın Türkçe içerik konusunda çektiği sıkıntılar düşünülerek soru/cevap şeklinde bir etkileşimde bulunabilmesi için kurduk. Umuyoruz hepimiz için güzel bir deneyim olur. Hasscript Ekibi

0
The Apache Tomcat installation at this directory is version 8.5.11. A Tomcat 8.0 installation is expected.

Açık 1 Cevaplar 296 Gösterim Java
Selam , Eclipse tomcat sunucusu eklerken aşağıdaki hatayı alıyorum.

 The Apache Tomcat installation at this directory is version 8.5.11.  A Tomcat 8.0 installation is expected.

neyi eksik yapıyor olabilirim yardımcı olurmusunuz.

1 cevap

0

araştırdığıma göre;

tomcat server ın altına catailna.jar ın içinde bulunan "ServerInfo.properties" dosyasının içinde bir güncelleme gerekiyormuş.

server.info=Apache Tomcat/8.5.11
server.number=8.5.11.0
server.built=Jan 10 2017 21:02:52 UTC

8.5.11 yazan kısımın 8.0.5.11 olarak değiştirmek gerekiyormuş.

Bu .properties dosyasını değiştirmek için jar dosyasını rar olarak açıp bir yere properties dosyasıı alıp değiştirin. Sonra tekrar bulunduğu yere geri atın. jar içinde çıkarmadan güncelleyemezsiniz.

Dosyanın bulunduğu directory ise;

apache-tomcat-8.5.11\lib\catalina.jar\org\apache\catalina\util\
(2.0k puan)
1Yorumlar
(2.0k puan)
ya da 8.0.xx  veriyonlu bir tomcat indirmek problemi çözüyor