Merhabalar arkadaşlar, Sitemizi programlama ile ilgilenen bütün arkadaşlarımızın türkçe içerik konusunda çektiği sıkıntılar düşünülerek soru/cevap şeklinde bir etkileşimde bulunabilmesi için kurduk. Umuyoruz hepimiz için güzel bir deneyim olur. Hasscript Ekibi

622 soru

648 cevap

194 yorum

127 üye

Hoş geldiniz!!

Ülkemizde yazılım sektöründe çalışan biriyseniz, çok fazla sorunla karşılaşıp sizde ani tepkiler veriyorsanız :), bazen günlerinizi harcayıp sonuca ulaşmaya çalışıyorsanız, yalnız değilsiniz. Tecrübelerimizi paylaşmak, tecrübelerinizden faydalanmak istediğimiz için buradayız.
Sizi de bekliyoruz.
0 oy
76

Eclipse 'de tomcat server eklemeye çalışıyorum. Ancak sitesinden düzgün şekilde indirmeme rağmen neden böyle bir hata verdiğini anlamadım.

"Unknown version of Tomcat was specified."
Sunucular kategorisinde (1.6k puan) sordu

2 Cevap

0 oy

Tomcat in bir bug ı olduğunu söylüyorlar, 

lib'in altındaki catalina.jar 'ın içindeki bir dosyayı güncelleyince probemim çözüdü. O da

C:\apache-tomcat-8.5.16\lib\catalina.jar\org\apache\catalina\util\

ServerInfo.properties  dosyası var onun içindeki tomat versiyonu 8.0.... olmasını bekliyormuş.

server.info=Apache Tomcat/8.0.5.16
server.number=8.0.5.16.0
server.built=Jun 21 2017 17:01:09 UTC
(1.6k puan) cevapladı
0 oy
Tomcat 8.5 sürümünü 8.0 olarak kurmaya çalışmış gibi görünüyorsun. Tomcat 8.5 için ayrı bir adaptör var Eclipse'de onu da indirsen oluyor. Geçenlerde ben de denedim. Sıkıntı çıkmadı. Aynı şey olduğunu sanıyorum ama emin olamadım.
(2.9k puan) cevapladı
ayrı plugin indirilirse halledilebileceği de geçiyor bazı yerlerde. Ben 2 kere karşılaştım malesef bu sorunla. Normalde olmuyordu. Çözümü bu şekilde yaptım. 8.5 olarak isim vermeye calışmıştım ama yememişti. Bu yönteme başvurdum. Belkide eclipsin sorunu olabilir.
...